注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Tales~曾经的我们~

想起你的好

 
 
 

日志

 
 
关于我

专业化学。爱好文学。同时还喜欢美术、摄影、哲学、经济学、新闻传播学和计算机。目前乐器小提琴,最想学的乐器是钢琴。对ACG有爱。

网易考拉推荐

KNIME无法启动的解决办法  

2010-10-21 15:09:00|  分类: Computer |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
商业智能工具KNIME是基于Eclipse环境的开源商业智能工具,目前最新版本为2010年9月30日发布的2.2.2版。
KNIME 是通过工作流来控制数据的集成、清洗、转换、过滤,再到统计、数据挖掘,最后是数据的可视化。整个开发都在可视化的环境下进行,通过简单的拖曳和设置就可以完成一个流程的开发。通过KNIME的白皮书得知KNIME的全称是The Konstanz Information Miner。它的设计目的是用于教学、研究以及协同工作的平台。(以上介绍来自网络)
在Ubuntu 10.04以及10.10版本中,KNIME无法正确启动。查看相关日志,根据官方论坛的讨论及FAQ(详情参加以下地址:地址1地址2地址3地址4),初步得知无法启动的原因是eclipse、mozilla、xulrunner之间版本不匹配。相关版本匹配信息如下:
  • Eclipse 3.0.x: Mozilla 1.4 GTK2 - 1.6 GTK2.
  • Eclipse 3.1.x: Mozilla 1.4 GTK2 - 1.7.8 GTK2.
  • Eclipse 3.2.x: Mozilla 1.4 GTK2 - 1.7.x GTK2.
  • Eclipse 3.3.x: Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x.
  • Eclipse 3.4.x: Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.0.x.
  • Eclipse 3.5.0: Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.1.x.
  • Eclipse 3.5.2: Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.2.x.
  • Eclipse 3.6.0: Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.2.x, and WebKitGTK+ 1.2.0 and above
  • 解决办法如下:
    1.安装新版Eclipse。Ubuntu软件源里面的版本为3.5.2,安装这个即可。
    2.安装1.8.x版本的XULRunner
    3.打开knime.ini,在最后一行加上
    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/mozilla

    以上三种方法理论上任选一种即可,之后双击KNIME图标,即可正确启动。(右上角红字提示的错误暂时没解决)
    KNIME无法启动的解决办法 - Tales - Tales~曾经的我们~
     


      评论这张
     
    阅读(730)| 评论(2)
    推荐 转载

    历史上的今天

    在LOFTER的更多文章

    评论

    <#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
     
     
     
     
     
     
     
     
     
     
     
     
     
     

    页脚

    网易公司版权所有 ©1997-2017