注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Tales~曾经的我们~

想起你的好

 
 
 

日志

 
 
关于我

专业化学。爱好文学。同时还喜欢美术、摄影、哲学、经济学、新闻传播学和计算机。目前乐器小提琴,最想学的乐器是钢琴。对ACG有爱。

网易考拉推荐

在UBUNTU 16.04中安装为知笔记deb包  

2017-09-03 16:32:29|  分类: Computer |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
照例,脱水版直接看文末。

当年各大笔记软件打得火热的时候,我最终选择的为知笔记作为主力,印象笔记作为辅助。最大的一个原因就是为知笔记有Linux版本,而印象笔记只有使用开源替代版本或者网页版。当时印象笔记网页版使用体验不佳,开源版本在稳定性、功能性上不如官方版本,还有可能某一天就停止维护了(由于作者太忙,2017年也就2月更新过一次)。而为知笔记不仅有官方版本,还加入了PPA源,安装和使用都很方便。由于在工作中需要经常使用Linux系统,就选择了为知笔记。
随着“国产操作系统”噱头热度的减退和移动操作系统的崛起,国产软件在经过了一阵子Linux开发热潮之后,变得逐渐冷清起来。为知笔记也移除了PPA支持,并且不再提供deb包下载,需要用户自己git代码之后编译。官方给出了一个编译教程:
不过说实话,用户自己哪怕是新装一个UBUNTU 16.04系统,按照这个教程,也是编译不出来的。看着一大堆报错信息,我也不想花时间去折腾了。还好,deepin自己打包了一个deb包,于是决定自己下一个来试试,哪怕报错,解决起来应该也要容易的多。
首先去deepin镜像源列表页面,随便找一个镜像源:
比如他官方仓库:
之后在这个页面里:
可以找到一个deb包(64位系统):
wiznote_2.5.5-1_amd64.deb
嗯,2.5.5版本,几乎是最新的了(刚看了一下,最新版是2.5.6)
把这个包下载到本地,然后用命令行进行安装(不推荐双击打开安装。UBUNTU系统双击会默认打开软件商店,难用到无法描述。如果喜欢双击安装的话,推荐用GDebi。)

tales@tales:~/下载$ sudo dpkg -i wiznote_2.5.5-1_amd64.deb [sudo] tales 的密码: (正在读取数据库 ... 系统当前共安装有 220316 个文件和目录。) 正准备解包 wiznote_2.5.5-1_amd64.deb ... 正在将 wiznote (2.5.5-1) 解包到 (2.3.2.4) 上 ... dpkg: 依赖关系问题使得 wiznote 的配置工作不能继续: wiznote 依赖于 libssl1.0-dev;然而: 未安装软件包 libssl1.0-dev。 dpkg: 处理软件包 wiznote (--install)时出错: 依赖关系问题 - 仍未被配置 正在处理用于 desktop-file-utils (0.22-1ubuntu5.1) 的触发器 ... 正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) 的触发器 ... Rebuilding /usr/share/applications/bamf-2.index... 正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ... 正在处理用于 mime-support (3.59ubuntu1) 的触发器 ... 正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ... 在处理时有错误发生: wiznote

很不幸,报错。
看一下报错信息,是软件包libssl1.0-dev引起的。在UBUNTU仓库里只有libssl-dev这个包,那看来就是版本号导致的依赖错误。那我们先取消刚才的安装,修复依赖损坏。

sudo apt-get install -f

接下来安装libssl-dev:

sudo apt-get install libssl-dev

之后我们解包为知笔记的deb包:

mkdir wiznote mkdir wiznote/DEBIAN dpkg -X wiznote_2.5.5-1_amd64.deb wiznote dpkg -e wiznote_2.5.5-1_amd64.deb wiznote/DEBIAN

deb包的依赖信息保存在/wiznote/DEBIAN这个文件夹的control文件里。打开文件,找到依赖信息:

Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0),libstdc++6 (>= 5.2), libx11-6, zlib1g (>= 1:1.1.4), libssl1.0-dev

将libssl1.0-dev修改为libssl-dev:

Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0),libstdc++6 (>= 5.2), libx11-6, zlib1g (>= 1:1.1.4), libssl-dev

之后重新打包成deb包:

sudo dpkg-deb -b wiznote.deb

再次安装:

sudo dpkg -i wiznote.deb

安装成功。
在UBUNTU 16.04中安装为知笔记deb包 - Tales - Tales~曾经的我们~

--------------------------------
脱水版:
为知笔记2.5.5版本deb包下载(适用于UBUNTU 16.04 64位系统):
链接: https://pan.baidu.com/s/1bplgHQn 密码: re2r





  评论这张
 
阅读(60)| 评论(3)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017